Introduction to Macromedia Flash
Getting started overview
Welcome to Macromedia Flash MX 2004 and Macromedia Flash MX Professional 2004. Flash provides everything you need to create and deliver rich web content and powerful applications. Whether you're designing motion graphics or building data-driven applications, Flash has the tools necessary to produce great results and deliver the best user experience across multiple platforms and devices.
This guide is designed to introduce you to Flash. The tutorial in this guide leads you through the process of creating a simple Flash application.

About Flash
Flash is an authoring tool that allows you to create anything from a simple animation to a complex interactive web application, such as an online store. You can make your Flash applications media rich by adding pictures, sound, and video. Flash includes many features that make it powerful but easy to use, such as drag-and-drop user interface components, built-in behaviors that add ActionScript to your document, and special effects that you can add to objects.
When you author in Flash you work in a Flash document, a file that, when saved, has the file extension .fla. When you are ready to deploy your Flash content, you publish it, creating a file with the extension .swf. The Flash Player, described in the next section, runs the SWF file.

About the Flash Player
Macromedia Flash Player 7, which runs the applications that you create, installs by default along with Flash. The Flash Player ensures that all SWF content is viewable and available consistently and across the broadest range of platforms, browsers, and devices.
The Macromedia Flash Player is distributed with products from every major partner, including Microsoft, Apple, Netscape, AOL, and Opera, to bring rich content and applications immediately to over 516 million people worldwide. The Flash Player is distributed freely to anyone who wants to use it. You can get the latest version of the Flash Player at the Macromedia Flash Player Download Center.

What's new
There are now two editions of Flash: Flash MX 2004 and Flash MX Professional 2004. To verify which edition you have installed, select Help > About Flash in the application.
Flash MX 2004 Flash MX 2004 is the perfect tool for the web designer, interactive media professional, or subject matter expert developing multimedia content. Emphasis is on creation, import, and manipulation of many types of media (audio, video, bitmaps, vectors, text, and data).
Flash MX Professional 2004 Flash MX Professional 2004 is designed for advanced web designers and application builders. Flash MX Professional 2004 includes all the features of Flash MX 2004, along with several powerful new tools. It provides project-management tools for optimizing the workflow between the members of a web team made up of designers and developers. External scripting and capabilities for handling dynamic data from databases are some of the features that make Flash particularly suitable for large-scale, complex projects deployed using the Flash Player along with a hybrid of HTML content.

New features available in both Flash MX 2004 and Flash MX Professional 2004
The new features in Flash MX 2004 and Flash MX Professional 2004 provide greater productivity, enhanced rich media support, and streamlined publishing.
[bookmark: 145289]Productivity
Flash MX 2004 and Flash MX Professional 2004 include many features designed specifically for streamlining previously complex tasks, thereby improving productivity:
Timeline effects You can apply Timeline effects to any object on the Stage to quickly add transitions and animations such as fade-ins, fly-ins, blurs, and spins. For more information, see Using Timeline effects.
Behaviors With behaviors, you can add interactivity to Flash content without writing a line of code. For example, you can use behaviors to include functionality that links to a website, loads sounds and graphics, controls playback of embedded videos, plays movie clips, and triggers data sources. For more information, see Controlling instances with behaviors.
Accessibility support in the authoring environment Accessibility support in the Flash authoring environment provides keyboard shortcuts for navigating and for using interface controls, letting you work with these interface elements without using the mouse. For more information, see Accessibility in the Flash authoring environment.
Updated templates Flash includes updated templates for creating presentations, e-learning applications, advertisements, mobile device applications, and other commonly used types of Flash documents. For more informations, see Using templates.
Integrated Help system The new Help panel provides in-context reference, ActionScript reference, and lessons in the Flash authoring environment. For more information, see Using the Help panel.
Spell checker The spell checker searches your text for spelling errors. For more information, see Checking spelling.
Document tabs Tabs for each open document are displayed at the top of the workspace so that you can quickly locate and switch between open documents. For more information, see Using document tabs for multiple documents (Windows only).
Start page The Start page puts commonly used tasks at your fingertips, in a central page. For more information, see Using the Start page.
Find and Replace The Find and Replace feature locates and replaces a text string, a font, a color, a symbol, a sound file, a video file, or an imported bitmap file. For more information, see Using Find and Replace.
[bookmark: 145328]Rich media support
New rich media support features enhance the quality of rich media presentations.
High-fidelity import High-fidelity import lets you import Adobe PDF and Adobe Illustrator 10 files and preserve accurate vector representation of your source files. For more information, see Importing Adobe Illustrator, EPS, or PDF files.
Video Import wizard The Video Import wizard simplifies video encoding and offers encoding presets and clip editing. For more information, see Using the Video Import wizard.
Small font size rendering Small font sizes are now rendered more crisply. For more information, see Creating text.
Publishing
New publishing features make it easy to detect Flash Player versions, improve accessibility, and simplify localization.
Flash Player detection You can now publish SWF files with associated files that detect if a user has a specified Flash Player version. You can configure your published files to direct users to alternate files if they don't have the specified Flash Player. For more information, see Configuring publish settings for Flash Player detection.
Publish profiles You can create profiles to save your publish settings, then export the profiles and use them across projects to publish consistently under different conditions. For more information, see Creating a publish profile.
Accessibility and components New accessibility features and a new generation of components offer tab ordering, tab focus management, and improved support for third-party screen readers and closed-caption programs.
Globalization and Unicode Enhanced globalization and Unicode support allows multilanguage authoring using any character set. For more information, see Creating Multilanguage Text.
Strings panel The new Strings panel makes it easier to publish Flash content in multiple languages. With the click of a few buttons, Flash creates external XML files for each specified language. For more information, see Creating Multilanguage Text.
Security The Flash Player 7 enforces a stricter security model than previous versions of the Flash Player. Exact domain matching requires that the domain of the data to be accessed match the data provider's domain exactly in order for the domains to communicate. HTTPS/HTTP restriction specifies that a SWF file using nonsecure (non-HTTPS) protocols cannot access content loaded using a secure (HTTPS) protocol, even when both are in exactly the same domain. For more information see Flash Player security features.
[bookmark: 145367]
Other improvements
Flash Player performance has been greatly improved, and ActionScript has been enhanced to comply with ECMA script language specifications. Also, Flash now tracks interactions so that they can be converted to reusable commands.
Flash Player runtime performance Player runtime performance has been improved by a factor of two to five times for video, scripting, and general display rendering.
ActionScript 2 ActionScript 2 is an object-oriented language that follows the ECMA script language specification and supports inheritance, strong typing, and the event model. For more information, see ECMA-262 Edition 4 compliance (you may need to update your Help system to see this information).
History panel The History panel tracks your actions so that they can be converted to reusable commands. For more information, see Using the History panel.

New features available in Flash MX Professional 2004 only
Flash MX Professional 2004 offers all the features available in Flash MX 2004, plus a variety of new features to enhance application development and design. Features include the screen-based visual development environment, and tools for managing data interactively and for fostering team productivity.

[bookmark: 112779]Screen-based visual development environment
A visual programming environment Flash MX Professional 2004 introduces a forms-based visual programming environment, which is ideal for developing applications. For more information, see Slide screens and form screens (Flash Professional only).
Slides-based authoring Slide screens provide functionality designed for sequential presentations. For more information, see Slide screens and form screens (Flash Professional only).

[bookmark: 117456]A new generation of components
Advanced components support New components now support focus management to control tab navigation. Although the components have a new sophisticated design, you can easily reskin them to modify their appearance. For more information, see Benefits of v2 components.

[bookmark: 112788]Data interactivity
Data binding Data binding allows you to connect any component to various data sources to manipulate, display, and update data through components or ActionScript. For more information, see Data Integration (Flash Professional Only).
Prebuilt data connectors for Web Services and XML New components allow you to connect to web services and XML data sources easily. For more information, see Components Dictionary.
Performance improvements Performance improvements on large record sets allow your application to work efficiently with large amounts of data.
[bookmark: 112797]Team productivity
Project management The Project panel enables centralized project file management, version control, and workflow optimization for teams of Flash users working together. For more information, see Working with Projects (Flash Professional Only).
Source code control Flash Professional provides source code control integration with plug-ins to industry-leading source control systems such as Microsoft Visual Source Safe. For more information, see Using version control with projects (Flash Professional only).
Instructional media
Flash contains a variety of media to help you learn the program quickly and become proficient in creating your own Flash applications.

About the electronic manuals and lessons
The following electronic manuals are available through the Help panel (Help > Help):
· Getting Started provides a hands-on introduction to Flash.
· Using Flash contains complete information on working in the Flash authoring tool, including all commands, features, and user interface elements.
· Using Components contains information on adding and configuring components in a Flash document, as well as information on creating components.
· The ActionScript Reference Guide provides a conceptual introduction to the ActionScript language and documents all actions, methods, and properties in the ActionScript API.
If you are a new user, you'll find the following information useful:Getting Started provides basic information about the Flash workspace and guides you in creating a simple document.
A series of lessons on the How Do I tab offer an introduction to using Flash. Refer to the Quick Tasks, Basic Flash, and Basic ActionScript lessons (Help > How Do I).

Using the Help panel
The updatable Help panel provides access to information on how to use Flash. For more information about the Help panel, see the following sections.
[bookmark: 111242]Accessing help
The tabs in the Help panel—Help and How Do I—contain the full set of user assistance information provided with the Flash application.
· You can select the Help tab to display general help information.
· You can select the How Do I tab to display a list of 10-20 minute lessons that guide you through many of the features in Flash.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To access help and the table of contents:
1. Select Help > Help to open the Help panel.
2. [image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\icons\uas_tree.gif]If the table of contents is not visible, click the Table of Contents button to display the table of contents.
A list of help books is displayed. The Help tab is selected by default.
3. Click a book to open it and display its topics.
4. Click a topic to select it.
The How Do I tab contains brief lessons that introduce you to the main features of Flash, letting you practice on isolated examples. If you are new to Flash, or if you have used only a limited set of features, start with the How Do I tab.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To start the lessons:
1. Select Help > How Do I to display the How Do I tab of the Help panel.
In the Table of Contents, you'll find a list of lessons.
2. Click a lesson topic to open it.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To search for a word or phrase in the Help panel:
1. [image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\icons\uas_search.gif]Click the Search icon in the Help panel toolbar.
2. Type a word or phrase in the text box, then click Search.
A list of topics that contain the word or phrase is displayed.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To close the help table of contents:
· To close the table of contents, click the X above the table of contents.
Note: You can access the table of contents again by clicking the Table of Contents button.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To print a help page:
1. [image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\icons\uas_print.gif]Click the Print button in the Help panel toolbar.
2. In the Print dialog box, select the printer and other printing options, then click Print.
[bookmark: 111211]Updating the Help panel
The Update feature allows you to update your help system with new and revised documentation, including procedures and lessons. You can click the Update button to see if new information is available. Additionally, if you see a topic in help with the text "For the latest information about this topic, click the Update button at the top of the Help tab," you can click this button to update Flash Help.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To update Flash Help:
1. Verify that you're connected to the Internet.
2. [image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\icons\uas_toggle1.gif]Click the Update button in the Help panel toolbar and follow instructions to download the help system.
Using the Start page
The Start page provides easy access to your most frequently used actions, either at the start of a session or whenever no open documents are in the application window.
The Start page contains the following areas:
Open a Recent Item lets you view your most recent documents.
0pen displays the Open File dialog box.
Create New offers a list of file types from which to choose, such as ActionScript or document, for a quick way to open a new file.
Create from Template lists the templates most commonly used to create new documents and allows you to select from the list.
More opens the New Document dialog box, which lists additional document types that you can select.
Extend links to the Macromedia Flash Exchange website, where you can download additional applications and information.
Learn offers quick access to resources that assist you in learning Flash. You can take a tour of Flash, take a lesson, and update your help system with the latest documentation.
The Start page can also display trial conversion information, upgrade notices, and additional messages of interest.
You can choose whether to display the Start page.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To hide the Start page:
· On the Start page, select Don't Show Again.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To specify that the Start page appear again, do one of the following:
· (Windows) Select Edit > Preferences and click Show Start Page on the General tab.
· (Macintosh) Select Flash > Preferences and click Show Start Page on the General tab.
Installing Flash overview
This chapter explains the following:
· The system requirements for running Flash (see System requirements)
· How to install Flash (see Installing and activating Flash).
· How to customize Flash for a network (see About Flash Player security configurations on corporate networks)
How to configure a server for the Flash Player (see Configuring a server for the Flash Player).

System requirements
The following hardware and software are required to run Macromedia Flash MX 2004 and Macromedia Flash MX Professional 2004.
[bookmark: 111251]Authoring
The following hardware and software are required to install the Flash authoring tool.
	Windows
	Macintosh

	600 MHz Intel Pentium III processor or equivalent Windows 98 SE, Windows 2000, or Windows XP
	500 MHz PowerPC G3 processor Mac OS X 10.2.6

	128 MB RAM (256 MB recommended)
	128 MB RAM (256 MB recommended)

	190 MB available disk space
	130 MB available disk space



To install Flash MX 2004 and Flash MX Professional 2004, you must have administrative privileges. You must also have administrative privileges to remove any edition of Flash.
Flash MX 2004 and Flash MX Professional 2004 do not support Macintosh hard disks formatted with UFS. Apple has documented several UFS formatting issues for Carbon and Classic. Unless you are using native applications (Cocoa), UFS is not recommended or supported by Apple.
[bookmark: 111347]Flash Player 7
The following table lists system and browser requirements for Flash Player 7.
	Platform
	Browser

	Windows 98
	Microsoft Internet Explorer 5.x, Netscape 4.7, Netscape 7.x, Mozilla 1.x, AOL 8, and Opera 7.11

	Windows Me
	Microsoft Internet Explorer 5.5, Netscape 4.7, Netscape 7.x, Mozilla 1.x, AOL 8, and Opera 7.11

	Windows 2000
	Microsoft Internet Explorer 5.x, Netscape 4.7, Netscape 7.x, Mozilla 1.x, CompuServe 7, AOL 8, and Opera 7.11

	Windows XP
	Microsoft Internet Explorer 6.0, Netscape 7.x, Mozilla 1.x, CompuServe 7, AOL 8, and Opera 7.11

	Mac OS 9.x
	Microsoft Internet Explorer 5.1, Netscape 4.8, Netscape 7.x, Mozilla 1.x, and Opera 6

	Mac OS X 10.1.x, or Mac OS X 10.2.x
	Microsoft Internet Explorer 5.2, Netscape 7.x, Mozilla 1.x, AOL 7, Opera 6, and Safari 1.0 (Mac OS X 10.2.x only)



Installation and activation
Installing Flash is an automated process. After installation, you can choose to run the 30-day trial mode of Flash, or you can choose to activate either Flash MX 2004 or Flash MX 2004 Professional. Both editions of Flash must be activated over the Internet or phone prior to use, and you need your serial number to activate either edition of Flash unless you wish to select trial mode. Windows 98 SE users must have Microsoft Internet Explorer 5.1 or later in order to activate over the Internet.
Note: Installing Macromedia Flash MX 2004 and Macromedia Flash MX Professional 2004 does not overwrite earlier Flash versions, such as Macromedia Flash MX, that you might have installed.

[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To install Flash:
1. Close any running versions of Flash before installing.
2. Do one of the following to start the installation process:
· (Windows) If you have a CD, insert it in your CD drive. A Flash movie plays that guides you through installation choices.
Note: You can also run Install Flash MX 2004.exe to start the Flash movie, if necessary.
· (Macintosh) If you have a CD, insert it in your CD drive and double-click the Installer icon.
· If you have downloaded Flash from the Internet, double-click FlashMX2004Installer.exe (Windows), or double-click the Installer icon (Macintosh) and follow the onscreen instructions.
3. When installation is complete, follow the instructions to select the 30-day trial period, or enter your serial number and activate Flash.
Upgrading from Macromedia Flash MX 2004 to Macromedia Flash MX Professional 2004
If you've purchased Macromedia Flash MX 2004, you can upgrade to Macromedia Flash MX Professional 2004.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To upgrade to Macromedia Flash MX Professional 2004:
1. Select Help > Upgrade to Flash MX Professional 2004.
2. In the dialog box that appears, do one of the following:
· Select Buy to open a browser for the Macromedia store.
· Select Try and follow the instructions to obtain a serial number for a trial upgrade.
At the end of the trial period, if you do not purchase the upgrade, your application reverts to Macromedia Flash MX 2004.

Switching between trial mode editions
If you're running the trial mode of one edition of Flash, you can change to another edition during the same trial period.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To switch between trial modes:
· From Flash, select Help > Switch to Flash MX Professional 2004 or Switch to Flash MX 2004, depending on which trial mode you're already using, and which you wish to try.
A dialog box appears indicating that you must restart your computer for the change to take effect.

Purchasing a Flash edition from trial mode
If you're running Flash in trial mode, you can initiate your purchase directly from the application.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To purchase Flash from trial mode:
1. Select Help > Activate Macromedia Flash MX.
2. In the dialog box that appears, select Buy One Online to purchase a serial number.
A browser window takes you to the Macromedia store.
Changing or removing Flash Player
You can change or reinstall the current version of Flash Player.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To change or reinstall the ActiveX control for Windows (Internet Explorer or AOL): 
1. Close your browser.
2. Remove any currently installed versions of the ActiveX control. For instructions, see Technote 14157 on the Macromedia Flash Support Center.
3. Run the Install Flash Player 7 AX.exe file in your Players folder to begin installation.
4. Open the browser. The new version of the ActiveX control should be installed.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To change or reinstall the plug-in for Windows (Netscape, Mozilla, CompuServe, or Opera):
1. Close your browser before installing a new version of the plug-in.
2. Remove any currently installed versions of the plug-in. For instructions, see Technote 14157 on the Macromedia Flash Support Center.
3. Run the Install Flash Player 7.exe file in your Players folder to begin installation.
4. Open the browser. The new version of the plug-in should be installed. To verify installation in Netscape, select Help > About Plug-ins from the browser menu.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To change or reinstall the plug-in for Macintosh (Netscape, Internet Explorer for Macintosh, Safari, AOL, Opera, or CompuServe):
1. Close your browser before installing a new version of the plug-in.
2. Remove currently installed versions of the plug-in. See 
3. 
4. 
5. 
6. 

Technote 14157 on the Macromedia Flash Support Center for instructions.
7. Run Install Flash Player 7 (Mac OS 9.x) or Install Flash Player 7 OS X (Mac OS X.x) in your Players folder to begin installation.
8. Open the browser. The new version of the plug-in should be installed. To verify on Netscape, select Help > About Plug-ins from the browser menu.
Flash Player server configuration
For users to view your Flash content on the web, the web server must be properly configured to recognize SWF files.

Your server may already be configured properly. To test server configuration, see TechNote 4151 on the Macromedia Flash Support Center. If your server is not properly configured, follow the procedure below to configure it.
Configuring a server establishes the appropriate Multipart Internet Mail Extension (MIME) types so that the server can identify files with the .swf extension as Shockwave Flash files.
A browser that receives the correct MIME type can load the appropriate plug-in, control, or helper application to process and properly display the incoming data. If the MIME type is missing or not properly delivered by the server, the browser might display an error message or a blank window with a puzzle piece icon.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To configure a server for the Flash Player, do one of the following:
· If your site is established through an Internet service provider (ISP), ask the ISP to add this MIME type to the server: application/x-shockwave-flash with the SWF suffix.
· If you are administering your own server, see your web server documentation for instructions on adding or configuring MIME types.

About Flash Player security configurations on corporate networks
Corporate and enterprise system administrators can configure Flash to restrict access by the Flash Player to resources in the local file system. You can create a security configuration file that limits Flash Player functionality on the local system.
The security configuration file is a text file placed in the same folder as the Flash Player installer. The Flash Player installer reads the configuration file during installation and follows its security directives. The Flash Player exposes the configuration file to ActionScript using the System object.
With the configuration file, you can disable access by the Flash Player to the camera or microphone, limit the amount of local storage the Flash Player can use, control the auto-update feature, and block the Player from reading anything from the user's local hard disk.
For more information about security, see System class.

Getting to know the workspace overview
The Macromedia Flash MX 2004 and Macromedia Flash MX Professional 2004 workspace consists of a Stage on which you place media content, a main toolbar with menus and commands for controlling application functionality, panels and a Property inspector for organizing and modifying media assets, and a toolbar with tools for creating and modifying vector graphic content. For more information on the workspace, see the following sections:
· Moving the view of the Stage
· Using the Timeline
· Using frames and keyframes
· Using layers
· About the main toolbar and edit bar
· Using the toolbar
· Using the grid, guides, and rulers
· Using panels and the Property inspector
You can select preferences to modify the default Flash workspace. Context menus and keyboard shortcuts provide ways for you to easily navigate the Flash authoring environment. Special workspace accessibility features provide additional keyboard shortcuts that let you navigate panels and dialog boxes without using the mouse. See the following sections:
· Setting preferences in Flash
· Customizing keyboard shortcuts
· Using context menus
· Accessibility in the Flash authoring environment
Working with the stage
The Stage is the rectangular area where you place graphic content, including vector art, text boxes, buttons, imported bitmap graphics or video clips, and so on. The Stage in the Flash authoring environment represents the rectangular space in the Macromedia Flash Player where your Flash document is displayed during playback. You can zoom in and out to change the view of the Stage as you work.
The grid, guides, and rulers help you position content precisely on the Stage. See Using the grid, guides, and rulers.

Zooming
To view the entire Stage on the screen, or to view just a particular area of your drawing at high magnification, you can change the magnification level. The maximum magnification depends on the resolution of your monitor and the document size. The minimum value for zooming out on the Stage is 8%. The maximum value for zooming in on the Stage is 2000%.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To magnify or reduce your view of the Stage, do one of the following:
· To zoom in on a certain element, select the Zoom tool in the toolbar and click the element. To switch the Zoom tool between zooming in or out, use the Enlarge or Reduce modifiers (in the options area of the toolbar when the Zoom tool is selected) or Alt-click (Windows) or Option-click (Macintosh).
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\Help\GettingStarted\images\magnifying_glass.jpg]
· To zoom in on a specific area of your drawing, drag a rectangular selection marquee with the Zoom tool. Flash sets the magnification level so that the specified rectangle fills the window.
· To zoom in on or out of the entire Stage, select View > Zoom In or View > Zoom Out.
· To zoom in or out by a specified percentage, select View > Magnification and select a percentage from the submenu, or select a percentage from the Zoom control at the lower left corner of the application window.
· To scale the Stage to fit completely in the given window space, select View > Magnification > Fit in Window.
· To display the contents of the current frame, select View > Magnification > Show All, or select Show All from the Zoom control at the upper right of the application window. If the scene is empty, the entire Stage is displayed.
· To display the entire Stage, select View > Magnification > Show Frame or select Show Frame from the Zoom control at the lower left corner of the application window.
· To display the work area surrounding the Stage, select View > Work Area. The work area is shown in light gray. Use the Work Area command to view elements in a scene that are partly or completely outside of the Stage. For example, to have a bird fly into a frame, you would initially position the bird outside of the Stage in the work area.

Moving the view of the Stage
When the Stage is magnified, you may not be able to see all of it. The Hand tool lets you move the Stage to change the view without having to change the magnification.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To move the Stage view:
1. In the toolbar, select the Hand tool. To temporarily switch between another tool and the Hand tool, hold down the Spacebar and click the tool in the toolbar.
2. Drag the Stage.
Working with the Timeline
The Timeline organizes and controls a document's content over time in layers and frames. Like films, Flash documents divide lengths of time into frames. Layers are like multiple film strips stacked on top of one another, each containing a different image that appears on the Stage. The major components of the Timeline are layers, frames, and the playhead.
Layers in a document are listed in a column on the left side of the Timeline. Frames contained in each layer appear in a row to the right of the layer name. The Timeline header at the top of the Timeline indicates frame numbers. The playhead indicates the current frame displayed on the Stage.
The Timeline status display at the bottom of the Timeline indicates the selected frame number, the current frame rate, and the elapsed time to the current frame.
Note: When an animation is played, the actual frame rate is displayed; this may differ from the document frame rate if the computer can't display the animation quickly enough.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\Help\GettingStarted\images\timeline2.jpg]
You can change the way frames are displayed in the Timeline, as well as display thumbnails of frame content in the Timeline. The Timeline shows where there is animation in a document, including frame-by-frame animation, tweened animation, and motion paths. For more information on animation, see Creating Motion.
Controls in the layers section of the Timeline let you hide, show, lock, or unlock layers, as well as display layer contents as outlines. See Editing layers and layer folders.
You can insert, delete, select, and move frames in the Timeline. You can also drag frames to a new location on the same layer or to a different layer. See Working with frames in the Timeline.

Changing the appearance of the Timeline
By default, the Timeline appears at the top of the main application window, above the Stage. To change its position, you can dock the Timeline to the bottom or either side of the main application window, or display the Timeline as its own window. You can also hide the Timeline.
You can resize the Timeline to change the number of layers and frames that are visible. When there are more layers than can be displayed in the Timeline, you can view additional layers by using the scroll bars on the right side of the Timeline.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To move the Timeline: 
· Drag from the area above the Timeline header.
Drag the Timeline to the edge of the application window to dock it. Control-drag to prevent the Timeline from docking.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To lengthen or shorten layer name fields:
· Drag the bar separating the layer names and the frames portions of the Timeline.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To resize the Timeline, do one of the following: 
· If the Timeline is docked to the main application window, drag the bar separating the Timeline from the application window.
· If the Timeline is not docked to the main application window, drag the lower right corner (Windows) or the size box in the lower right corner (Macintosh).
Moving the playhead
The playhead moves through the Timeline to indicate the current frame displayed on the Stage. The Timeline header shows the frame numbers of the animation. To display a frame on the Stage, you move the playhead to the frame in the Timeline.
When you're working with a large number of frames that can't all appear in the Timeline at once, you can move the playhead along the Timeline to easily locate the current frame.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To go to a frame:
· Click the frame's location in the Timeline header, or drag the playhead to the desired position.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\Help\GettingStarted\images\move_playhead.jpg]
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To center the Timeline on the current frame:
· Click the Center Frame button at the bottom of the Timeline.

Changing the display of frames in the Timeline
You can change the size of frames in the Timeline, and display sequences of frames with tinted cells. You can also include thumbnail previews of frame content in the Timeline. These thumbnails are useful as an overview of the animation, but they require extra screen space.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\Help\GettingStarted\images\new_frame_view014.jpg]
Frame View pop-up menu
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\Help\GettingStarted\images\short_normal_frameview.jpg]
Short and Normal frame view options
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To change the display of frames in the Timeline:
1. Click the Frame View button in the upper right corner of the Timeline to display the Frame View pop-up menu.
2. Select from the following options:
· To change the width of frame cells, select Tiny, Small, Normal, Medium, or Large. (The Large frame-width setting is useful for viewing the details of sound waveforms.)
· To decrease the height of frame cell rows, select Short.
· To turn tinting of frame sequences on or off, select Tinted Frames.
· To display thumbnails of the content of each frame scaled to fit the Timeline frames, select Preview. This can cause the apparent content size to vary.
· To display thumbnails of each full frame (including empty space), select Preview in Context. This is useful for viewing the way elements move within their frames over the course of the animation, but previews are generally smaller than with the Preview option.
Frames and keyframes
A keyframe is a frame in which you define a change in an animation or include frame actions to modify a document. Flash can tween, or fill in, the frames between keyframes to produce fluid animations. Because keyframes let you produce animation without drawing each frame, they make creating animation easier. You can change the length of a tweened animation by dragging a keyframe in the Timeline.
The order in which frames and keyframes appear in the Timeline determines the order in which they are displayed in a Flash application. You can arrange keyframes in the Timeline to edit the sequence of events in an animation.

Working with frames in the Timeline
In the Timeline, you work with frames and keyframes, placing them in the order you want the objects in the frames to appear. You can change the length of a tweened animation by dragging a keyframe in the Timeline.
You can perform the following modifications on frames or keyframes:
· Insert, select, delete, and move frames or keyframes
· Drag frames and keyframes to a new location on the same layer or on a different layer
· Copy and paste frames and keyframes
· Convert keyframes to frames
· Drag an item from the Library panel onto the Stage to add the item to the current keyframe
The Timeline provides a view of tweened frames in an animation. For information on editing tweened frames, see Editing animation.
Flash offers two different methods for selecting frames in the Timeline. In frame-based selection (the default) you select individual frames in the Timeline. In span-based selection, the entire frame sequence, from one keyframe to the next, is selected when you click any frame in the sequence. You can specify span-based selection in Flash preferences. See Setting preferences in Flash.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To insert frames in the Timeline, do one of the following:
· To insert a new frame, select Insert > Timeline > Frame.
· To create a new keyframe, select Insert > Timeline > Keyframe, or right-click (Windows) or Control-click (Macintosh) the frame where you want to place a keyframe, and select Insert Keyframe from the context menu.
· To create a new blank keyframe, select Insert > Timeline > Blank Keyframe, or right-click (Windows) or Control-click (Macintosh) the frame where you want to place the keyframe, and select Insert Blank Keyframe from the context menu.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To select one or more frames in the Timeline:
· To select one frame, click on the frame. If you have Span Based Selection turned on in Preferences, clicking one frame selects the entire frame sequence between two keyframes. See Setting preferences in Flash.
· To select multiple contiguous frames, Shift-click additional frames.
· To select multiple discontiguous frames, Control-click (Windows) or Command-click (Macintosh) additional frames.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To select all frames in the Timeline:
· Select Edit > Timeline > Select All Frames.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To delete or modify a frame or keyframe, do one of the following:

Working with layers
Layers are like transparent sheets of acetate stacked on top of each other. Layers help you organize the artwork in your document. You can draw and edit objects on one layer without affecting objects on another layer. Where there is nothing on a layer, you can see through it to the layers below.
To draw, paint, or otherwise modify a layer or folder, you select the layer to make it active. A pencil icon next to a layer or folder name indicates that the layer or folder is active. Only one layer can be active at a time (although more than one layer can be selected at a time).
When you create a new Flash document, it contains one layer. You can add more layers to organize the artwork, animation, and other elements in your document. The number of layers you can create is limited only by your computer's memory, and layers do not increase the file size of your published SWF file. You can hide, lock, or rearrange layers.
You can also organize and manage layers by creating layer folders and placing layers in them. You can expand or collapse layers in the Timeline without affecting what you see on the Stage. It's a good idea to use separate layers or folders for sound files, actions, frame labels, and frame comments. This helps you find these items quickly when you need to edit them.
In addition, you can use special guide layers to make drawing and editing easier, and mask layers to help you create sophisticated effects.
For an interactive introduction to working with layers in Flash, select Help > How Do I > Basic Flash > Work with Layers.
Creating layers and layer folders
When you create a new layer or folder, it appears above the selected layer. A newly added layer becomes the active layer.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To create a layer, do one of the following:
· [image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\icons\layer_new.gif]Click the Insert Layer button at the bottom of the Timeline.
· Select Insert > Timeline > Layer.
· Right-click (Windows) or Control-click (Macintosh) a layer name in the Timeline and select Insert Layer from the context menu.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To create a layer folder, do one of the following:
Editing layers and layer folders
You can rename, copy, and delete layers and folders. You can also lock layers and folders to prevent them from being edited.
By default, new layers are named by the order in which they are created: Layer 1, Layer 2, and so on. You can rename layers to better reflect their contents.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To select a layer or folder, do one of the following:
· Click the name of a layer or folder in the Timeline.
· Click a frame in the Timeline of the layer you want to select.
· Select an object on the Stage that is located on the layer you want to select.
· To select two or more layers or folders, do one of the following:
· To select contiguous layers or folders, Shift-click their names in the Timeline.
· To select discontiguous layers or folders, Control-click (Windows) or Command-click (Macintosh) their names in the Timeline.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To rename a layer or folder, do one of the following:
· Double-click the name of a layer or folder and enter a new name.
· Right-click (Windows) or Control-click (Macintosh) the name of a layer or folder and select Properties from the context menu. Enter the new name in the Name text box and click OK.
· Select the layer or folder in the Timeline and select Modify > Timeline > Layer Properties. In the Layer Properties dialog box, enter the new name in the Name text box and click OK.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To lock or unlock one or more layers or folders, do one of the following:
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To copy a layer:
1. Click the layer name to select the entire layer.
2. Select Edit > Timeline > Copy Frames.
3. Click the Insert Layer button to create a new layer.
4. Click the new layer and select Edit > Timeline > Paste Frames.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To copy the contents of a layer folder:
1. Click the triangle to the left of the folder name to collapse it, if necessary.
2. Click the folder name to select the entire folder.
3. Select Edit > Timeline > Copy Frames.
4. Select Insert > Timeline > Layer Folder to create a new folder.
5. Click the new folder and select Edit > Timeline > Paste Frames.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To delete a layer or folder:
1. Select the layer or folder.
2. Do one of the following:
· Click the Delete Layer button in the Timeline.
· Drag the layer or folder to the Delete Layer button.
· Right-click (Windows) or Control-click (Macintosh) the layer or folder name and select Delete Layer from the context menu.
Note: When you delete a layer folder, all the enclosed layers and all their contents are also deleted.

Organizing layers and layer folders
You can rearrange layers and folders in the Timeline to organize your document.
Layer folders help organize your workflow by letting you place layers in a tree structure. You can expand or collapse a folder to see the layers it contains without affecting which layers are visible on the Stage. Folders can contain both layers and other folders, allowing you to organize layers in much the same way you organize files on your computer.
The layer controls in the Timeline affect all layers within a folder. For example, locking a layer folder locks all layers within that folder.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To move a layer or layer folder into a layer folder:
· Drag the layer or layer folder name to the destination layer folder name.
The layer or layer folder appears inside the destination layer folder in the Timeline.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To change the order of layers or folders:
· Drag one or more layers or folders in the Timeline to the desired position.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To expand or collapse a folder:
· Click the triangle to the left of the folder name.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To expand or collapse all folders:

Using guide layers
For help in aligning objects when drawing, you can create guide layers. You can then align objects on other layers to the objects you create on the guide layers. Guide layers do not appear in a published SWF file. You can make any layer a guide layer. Guide layers are indicated by a guide icon to the left of the layer name.
You can also create a motion guide layer to control the movement of objects in a motion tweened animation. See Tweening motion along a path.
Note: Dragging a normal layer onto a guide layer converts the guide layer to a motion guide layer. To prevent accidentally converting a guide layer, place all guide layers at the bottom of the layer order.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To designate a layer as a guide layer:

About the main toolbar and edit bar
The main toolbar at the top of the workspace displays menus with commands for controlling Flash functionality. The menus include File, Edit, View, Insert, Modify, Text, Commands, Control, Window, and Help.
The edit bar, directly below the main toolbar, contains controls and information for editing scenes and symbols, and for changing the magnification level of the Stage.
For information on changing the Stage magnification level, see Zooming. For information on editing symbols, see Using Symbols, Instances, and Library Assets. For information on working with scenes, see Working with scenes.
Working with the toolbar	
The tools in the toolbar let you draw, paint, select, and modify artwork, as well as change the view of the Stage. The toolbar is divided into four sections:
· The tools area contains drawing, painting, and selection tools.
· The view area contains tools for zooming and panning in the application window.
· The colors area contains modifiers for stroke and fill colors.
· The options area displays modifiers for the selected tool, which affect the tool's painting or editing operations.
Using the Customize Toolbar dialog box, you can specify which tools to display in the Flash authoring environment. See Customizing the toolbar.
For information on using the drawing and painting tools, see Flash drawing and painting tools. For information on using the selection tools, see Selecting objects.For information on using the view modification tools, see Moving the view of the Stage.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To show or hide the toolbar: 
· Select Window > Tools.
Selecting tools
You can select tools by clicking in the toolbar, or by using a keyboard shortcut.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To select a tool, do one of the following:
· Click the tool you want to use. Depending on the tool you select, a set of modifiers may be displayed in the options area at the bottom of the toolbar.
· Press the tool's keyboard shortcut.
· To select a tool located in the pop-up menu behind a visible tool, press the icon of the visible tool and select another tool from the pop-up menu.

Customizing the toolbar
You can customize the toolbar to specify which tools appear in the authoring environment. You use the Customize Toolbar dialog box to add or remove tools from the toolbar.
You can display more than one tool in one location. When more than one tool is displayed in a location, the top tool in the group (the most recently used) is displayed with an arrow in the lower right corner of its icon. When you press and hold the mouse button on the icon, the other tools in the group appear in a pop-up menu. You can drag to select a tool from the menu.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To customize the toolbar:
1. To display the Customize Toolbar dialog box, do one of the following:
· In Windows, select Edit > Customize Toolbar.
· On the Macintosh, select Flash > Customize Toolbar.
The Available Tools menu indicates the tools that are currently available in the Flash. The Current Selection menu indicates the tool (or tools) currently assigned to the selected location in the toolbar.
Note: If more than one tool is assigned to one location in the toolbar, the additional tools appear in a pop-up menu located behind the top tool in the group. A small arrow in the lower right corner of the top tool indicates that additional tools are present. The same keyboard shortcut functions for all tools in the group.
2. Click a tool in the toolbar graphic or use the arrows to cycle through the tools, to specify the location to which you want to assign another tool.
3. To add a tool to the selected location, select the tool in the Available Tools list and click the Add button. It is possible to assign a tool to more than one location.
4. To remove a tool from the selected location, select the tool in the Current Selection scroll list and click the Remove button.
5. Click OK to apply your changes and close the Customize Toolbar dialog box.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To restore the default toolbar layout
Using the grid, guides, and rulers
Flash comes with rulers and guides that help you draw and lay out objects precisely. You can place guides in a document and snap objects to those guides, or turn on the grid and snap objects to it.
Note: You can also snap objects to other objects or to pixels, or align objects using specified snap tolerance boundaries. See Snapping.
[bookmark: 78471]Using the grid
When the grid is displayed in a document, it appears as a set of lines behind the artwork in all scenes. You can snap objects to the grid, and you can modify the grid size and grid line color.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To display or hide the drawing grid:
· Select View > Grid > Show Grid.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To turn snapping to grid lines on or off:
· Select View > Snapping > Snap to Grid.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To set grid preferences:
1. Select View > Grid > Edit Grid.
2. For Color, click the triangle in the color box and select a grid line color from the palette.
The default grid line color is gray.
3. Select or deselect Show Grid to display or hide the grid.
4. Select or deselect Snap to Grid to turn snapping to grid lines on or off.
5. For grid spacing, enter values in the text boxes to the right of the horizontal and vertical arrows.
6. For Snap Accuracy, select an option from the pop-up menu.
7. If you want to save the current settings as the default, click Save Default.
[bookmark: 78490]Using guides
You can drag horizontal and vertical guides from the rulers onto the Stage when the rulers are displayed. You can move guides, lock guides, hide guides, and remove guides. You can also snap objects to guides, and change guide color and snap tolerance (how close objects must be to snap to a guide). Draggable guides appear only in the Timeline in which they were created.
You can clear all the guides in the current editing mode—document-editing mode or symbol-editing mode. If you clear guides in document-editing mode, all the guides in the document are cleared. If you clear guides in symbol-editing mode, all the guides in all symbols are cleared.
To create custom guides or irregular guides, you use guide layers. See Using guide layers.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To display or hide the drawing guides:
· Select View > Guides > Show Guides.
Note: If the grid is visible and Snap to Grid is turned on when you create guides, guides will snap to the grid.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To turn snapping to guides on or off:
· Select View > Snapping > Snap to Guides.
Note: Snapping to guides takes precedence over snapping to the grid in places where guides fall between grid lines.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To move a guide: 
· Use the Arrow tool to drag the guide.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To remove a guide: 
· With guides unlocked, use the Arrow tool to drag the guide to the horizontal or vertical ruler. For information on locking and unlocking guides, see the following procedure.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To lock guides:
· Select View > Guides > Lock Guides.
Note: You can also use the Lock Guides option in the Guides preferences dialog box. See the following procedure.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To set guide preferences:
1. Select View > Guides > Edit Guides and do any of the following:
· For Color, click the triangle in the color box and select a guide line color from the palette. The default guide color is green.
· Select or deselect Show Guides to display or hide guides.
· Select or deselect Snap to Guides to turn snapping to guides on or off.
· Select or deselect Lock Guides to lock or unlock guides.
· For Snap Accuracy, select an option from the pop-up menu.
· If you want to remove all guides, click Clear All.
· Clear All removes all guides from the current scene.
· If you want to save the current settings as the default, click Save Default.
2. Click OK.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To clear guides:
· Select View > Guides > Clear Guides.
If you are in edit document mode, all guides in the document are cleared. If you are in edit symbols mode, only guides used in symbols are cleared.
[bookmark: 78527]Using rulers
When rulers are displayed, they appear along the top and left sides of the document. You can change the unit of measure used in the rulers from the default of pixels. When you move an element on the Stage with the rulers displayed, lines indicating the element's dimensions appear on the rulers.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To display or hide rulers:
· Select View > Rulers.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To specify the rulers' unit of measure for a document: 
Setting preferences in Flash
Flash lets you set preferences for general application operations, editing operations, and Clipboard operations. See also Specifying drawing settings.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To set preferences:
1. Select Edit > Preferences (Windows) or Flash > Preferences (Macintosh).
2. Click the General, Editing, Clipboard, Warning, or ActionScript Editor tab, and select from the respective options as described in the procedures that follow. For more information on ActionScript Editor preferences, see Using the ActionScript editor.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To set general preferences, select from the following options:
· For Undo Levels, enter a value from 2 to 9999 to set the number of undo/redo levels. Undo levels require memory; the more undo levels you use, the more system memory is taken up. The default is 100.
· For Printing Options (Windows only), select Disable PostScript if you want to disable PostScript output when printing to a PostScript printer. By default, this option is deselected. Select this option if you have problems printing to a PostScript printer, but keep in mind that this will slow down printing.
· For Selection Options, select or deselect Shift Select to control how Flash handles selection of multiple elements. When Shift Select is off, clicking additional elements adds them to the current selection. When Shift Select is on, clicking additional elements deselects other elements unless you hold down the Shift key.
· Select Show Tooltips to display tooltips when the pointer pauses over a control. Deselect this option if you don't want to see the tooltips.
· For Timeline Options, select Disable Timeline Docking to keep the Timeline from attaching itself to the application window once it has been separated into its own window. For more information, see Using the Timeline.
· Select Span Based Selection to use span-based selection in the Timeline, rather than the default frame-based selection. For more information on span-based and frame-based selection, see Working with frames in the Timeline.
· Select Named Anchor on Scenes to have Flash make the first frame of each scene in a document a named anchor. Named anchors let you use the Forward and Back buttons in a browser to jump from scene to scene in a Flash application.
· For Highlight Color, select Use This Color and select a color from the palette, or select Use Layer Color (the default option) to use the current layer's outline color.
· For Font Mapping Default, select a font to use when substituting missing fonts in documents you open in Flash. See Substituting missing fonts.
· For On Launch options, select an option to specify which document Flash opens when you start the application. Select Show Start Page to display the Start Page. Select New Document to open a new, blank document. Select Last Documents Open to open the documents that were open when you last quit Flash. Select No Document to start Flash without opening a document.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To set editing preferences, do any of the following:
· For Pen Tool options, see Setting Pen tool preferences.
· For Vertical Text options, select Default Text Orientation to make the default orientation of text vertical, which is useful for some Asian language fonts. By default, this option is deselected.
· Select Right to Left Text Flow to reverse the default text display direction. This option is deselected by default.
· Select No Kerning to turn off kerning for vertical text. This option is deselected by default but is useful to improve spacing for some fonts that use kerning tables.
· For Drawing Settings, see Specifying drawing settings.
Note: If you are using Macromedia Flash MX Professional 2004, you can select Project preferences on the Editing tab, for closing and saving project files. See Creating and managing projects (Flash Professional only).
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To set Clipboard preferences, select from the following options:
· For Bitmaps (Windows only), select options for Color Depth and Resolution to specify these parameters for bitmaps copied to the Clipboard. Select Smooth to apply anti-aliasing. Enter a value in the Size Limit text box to specify the amount of RAM that is used when placing a bitmap image on the Clipboard. Increase this value when working with large or high-resolution bitmap images. If your computer has limited memory, select None.
· For Gradients (Windows only), select an option to specify the quality of gradient fills placed in the Windows Metafile. Choosing a higher quality increases the time required to copy artwork. Use this setting to specify gradient quality when pasting items to a location outside of Flash. When you are pasting within Flash, the full gradient quality of the copied data is preserved regardless of the Gradients on Clipboard setting.
· For PICT Settings (Macintosh only), for Type, select Objects to preserve data copied to the Clipboard as vector artwork, or select one of the bitmap formats to convert the copied artwork to a bitmap. Enter a value for Resolution. Select Include PostScript to include PostScript data. For Gradients, select an option to specify gradient quality in the PICT. Choosing a higher quality increases the time required to copy artwork. Use the Gradients setting to specify gradient quality when pasting items to a location outside of Flash. When you are pasting within Flash, the full gradient quality of the copied data is preserved regardless of the Gradient setting.
· For FreeHand Text, select Maintain Text as Blocks to keep text editable in a pasted FreeHand file.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To set warning preferences, select one of the following options:
· Select Warn on Save for Macromedia Flash MX Compatibility to have Flash warn you when you try to save documents with content specific to the Flash MX 2004 or Flash MX Professional 2004 authoring tool as a Flash MX file. This option is selected by default.
· Select Warn on Missing Fonts to have Flash warn you when you open a Flash document that uses fonts that are not installed on your computer. This option is selected by default.
· Select Warn on URL Changes in Launch and Edit to have Flash warn you if the URL for a document has changed since the last time you opened and edited it.
· Select Warn on Reading Generator Content to have Flash display a red X over any Generator objects, as a reminder that Generator objects are not supported in Flash MX 2004.
· Select Warn on Inserting Frames when Importing Content to have Flash alert you when it inserts frames in your document to accommodate audio or video files that you import.
· Select Warn on Encoding Conflicts When Exporting .as Files to have Flash alert you when selecting Default Encoding could potentially lead to data loss or character corruption. (For example, if you create a file with English, Japanese, and Korean characters and select Default Encoding on an English system, the Japanese and Korean characters will be corrupted.)
· Select Warn on Conversion of Effect Graphic Objects to have Flash warn you when you attempt to edit a symbol that has Timeline effects applied to it.
· Select Warn on Exporting to Flash Player 6 r65 to have Flash warn you when you export a document to this earlier version of the Flash Player.
· Select Warn on Sites with Overlapped Root Folder to have Flash warn you when you create a site in which the local root folder overlaps with another site.
· Select Warn on Behavior Symbol Conversion to have Flash warn you when you convert a symbol with a behavior attached to a symbol of a different type—for example, when you convert a movie clip to a button.
· Select Warn on Symbol Conversion to have Flash warn you when you convert a symbol to a symbol of a different type.
Customizing keyboard shortcuts
You can select keyboard shortcuts in Flash to match the shortcuts you use in other applications, or to streamline your Flash workflow. By default, Flash uses built-in keyboard shortcuts designed for the Flash application. You can also select a built-in keyboard shortcut set from one of several popular graphics applications, including Fireworks, Adobe Illustrator, and Adobe Photoshop.
To create a custom keyboard shortcut set, you duplicate an existing set, and then add or remove shortcuts from the new set. You can delete custom shortcut sets.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To select a keyboard shortcut set: 
1. Select Edit > Keyboard Shortcuts (Windows) or Flash > Keyboard Shortcuts (Macintosh).
2. In the Keyboard Shortcuts dialog box, select a shortcut set from the Current Set pop-up menu.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To create a new keyboard shortcut set:
1. Select a keyboard shortcut set as described in the previous procedure.
2. Click the Duplicate Set button.
3. Enter a name for the new shortcut set and click OK.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To rename a custom keyboard shortcut set:
1. In the Keyboard Shortcuts dialog box, select a shortcut set from the Current Set pop-up menu.
2. Click the Rename Set button.
3. In the Rename dialog box, enter a new name and click OK.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To add or remove a keyboard shortcut: 
1. Select Edit > Keyboard Shortcuts (Windows) or Flash > Keyboard Shortcuts (Macintosh) and select the set that you want to modify.
2. From the Commands pop-up menu, select Drawing Menu Commands, Drawing Tools, Test Movie Menu Commands, or Workplace Accessibility Commands to view shortcuts for the selected category.
3. In the Commands list, select the command for which you want to add or remove a shortcut.
An explanation of the selected command appears in the Description area in the dialog box.
4. Do one of the following:
· To add a shortcut, click the Add Shortcut (+) button.
· To remove a shortcut, click the Remove Shortcut (-) button and proceed to step 6.
5. If you are adding a shortcut, enter the new shortcut key combination in the Press Key text box.
Note: To enter the key combination, simply press the keys on the keyboard. You do not need to spell out key names, such as Control, Option, and so on.
6. Click Change.
7. Repeat this procedure to add or remove additional shortcuts.
8. Click OK.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To delete a keyboard shortcut set:
1. Select Edit > Keyboard Shortcuts (Windows) or Flash > Keyboard Shortcuts (Macintosh). In the Keyboard Shortcuts dialog box, click the Delete Set button.
2. In the Delete Set dialog box, select a shortcut set and click Delete.
Note: You cannot delete the built-in keyboard shortcut sets that ship with Flash.

Using context menus
Context menus contain commands relevant to the current selection. For example, when you select a frame in the Timeline window, the context menu contains commands for creating, deleting, and modifying frames and keyframes. Context menus exist for many items and controls in many locations, including on the Stage, in the Timeline, in the Library panel, and in the Actions panel.
[image: C:\Users\C5\AppData\Local\Macromedia\Flash MX 2004\en\Configuration\HelpPanel\_sharedassets\expand.gif]To open a context menu:




Prog 1
Aim: To create animation for moving a ball in rectangle shape using motion tween.
Procedure:
1. Select & open the macromedia flash and select new flash document.
2. Right click on the layer name area and edit the name as shape tween.
3. Select the rectangle tool and draw the round rectangle at the middle of the stage and group it using Ctrl + G.
4. Select the 90th frame from the timeline and right click on it and select insert key frame.
5. Create a new layer, rename it as ball and select the oval tool and draw the circle top left of the round rectangle.
6. Select 30th frame and right click on it, and select insert key frame and drag the circle on the right of the round rectangle and select any one of the frame between 0 and 30 and also apply motion tween.
7. Select 50th frame and select insert key frame and drag the ball to the right bottom of rectangle and apply motion tween.
8. Select the 80th frame and select insert key frame and drag the ball to the left bottom of rectangle and apply motion tween.
9. Select the 90th frame and select insert key frame and drag the ball to left top of the rectangle and apply motion tween.
10. Save the flash file as MotionTween.fla and run the file by pressing Ctrl + Enter.

Output:
[image: ][image: ]








Conclusion: The above program to moving a ball around the rectangle is successfully executed.


Prog 2
Aim: To create animation to change the shape of an object using shape tween.
Procedure:
1. Select & open the macromedia flash and select new flash document.
2. Right click on the layer name area and edit the name as rectangle.
3. Select the rectangle tool and draw the rectangle at the top left corner of the stage.
4. Select the 50th frame and select insert key frame and delete rectangle and select oval tool and draw the circle at the bottom right of the stage.
5. Select any one frame between 1 to 50 and set tween as shape.
6. Save the flash file as ShapeTween.fla and run the file by pressing Ctrl + Enter.

Output:
[image: ][image: ][image: ]
Conclusion: The above program to change the shape of an object using shape tween has been successfully executed.


Prog 3
Aim: To create animation to change the text to another text using text tween.
Procedure:
1. Select & open the macromedia flash and select new flash document.
2. Right click on the layer name area and edit the name as text tween.
3. Select the text tool and drag on the scene a text box and write some text in any format on the top left of the screen.
4. Select the text and right click on it and select break apart and again right click on it and select break a part.
5. Select the 50th or any frame and select insert key frame and delete before text and select text tool and write the same text in any format and right click on it and select break apart and again select break a part.
6. Select any one key frame between 0th to 50th or any frame and set properties as a shape tween.
7. Save the flash file as TextTween.fla and run the file by pressing Ctrl + Enter.

Output:
[image: ][image: ][image: ] 
Conclusion: The above program to change the text to another text using text tween has been successfully executed.
Prog 4
Aim: To create animation for masking color to the text using mask.
Procedure:
1. Select & open the macromedia flash and select new flash document.
2. Right click on the layer name area and edit the name as masking image.
3. Import the image to layer 1 as follows File -> import -> import to stage.
4. It shows the location where you have to choose an image.
5. Insert a new layer and rename it as text area.
6. Select the text tool and draw text box an image and write some text.
7. Select the text layer and right click on it and select mask it import the image color to text it means that image masks text.
8. Save the flash file as MaskImage.fla and run the file by pressing Ctrl + Enter.

Output:
[image: ]
Conclusion: The above program to create animation for masking color to the text using mask has been successfully executed.


Prog 5
Aim: To create animation as Bouncing a ball using motion tween.
Procedure:
1. Select & open the macromedia flash and select new flash document.
2. Right click on the layer name area and edit the name as rectangle.
3. Select the round rectangle and draw two horizontal straight lines parallel and group them.
4. Select the 60th frame and select insert layer and name it as ball.
5. Select layer name area and select insert layer and name it as ball.
6. Select 20th frame and select insert key frame and drag the ball angularly to below of the upper line.
7. And alternatively select the frames up to 60th frame and drag the ball between upper and lower line.
8. Select the frame in between frames of the ball and apply the motion tween.
9. Save the flash file as BouncingBall.fla and run the file by pressing Ctrl + Enter.
Output:
[image: ][image: ][image: ][image: ]
Conclusion: The above program to create animation as bouncing a ball using motion tween has been successfully executed.
Prog 6
Aim: To create animation for moving a truck.
Procedure:
1. Select & open the macromedia flash and select new flash document.
2. Right click on the layer name area and edit the name as road.
3. Select the line tool and draw two lines, select 50th frame and insert key frame.
4. Insert new layer and select the layer name area and rename it as truck.
5. Select the rectangle tool and draw the truck and group it by pressing Ctrl + G.
6. Select 50th frame and select insert key frame move the truck from 0th to 50th frame.
7. Apply the motion tween for truck.
8. Save the flash file as MovingTruck.fla and run the file by pressing Ctrl + Enter.

Output:
[image: ]
[image: ]
[image: ]


Conclusion: The above program to moving a truck has been successfully executed.

Prog 7
Aim: To an application in flash to show the concept of loop.
Procedure:
1. Select & open the macromedia flash and select new flash document.
2. Create a variable n and initialize it with value 5.
3. Use for loop and starts from 0 to less than n.
4. Display the loop iteration number.
5. Save the flash file as ForLoop.fla and run the file by pressing Ctrl + Enter.

Program:
var n=5;
for(i=0; i<n; i++)
trace(i);

Output:
[image: ]

Conclusion: The above program to show the concept of loop has been successfully executed.


Prog 8
Aim: To write an application in flash for generate the random numbers.
Procedure:
1. Select & open the macromedia flash and select new flash document.
2. Create a variable n and initialize it with value 5.
3. Use for loop and starts from 0 to less than n.
4. Display the random number using random() function.
5. Save the flash file as RandomNumber.fla and run the file by pressing Ctrl + Enter.

Program:
var n=10;
for(i=0; i<n; i++)
trace( random(i) );

Output:
[image: ]

Conclusion: The above program to generate the random numbers has been successfully executed.


Prog 9
Aim: To write an application in flash to display the multiplication of table.
Procedure:
1. Select & open the macromedia flash and select new flash document.
2. Create a variable n and initialize it with any value.
3. Use for loop and starts from 1 to 10
4. Display the table result in formatted style.
5. Save the flash file as MultiplicationTable.fla and run the file by pressing Ctrl + Enter.

Program:
var n = 2;
for(i=1; i<=10; i++)
trace( n + " * " + i + " = " + n*I );

Output:
[image: ]

Conclusion: The above program to display the multiplication of table has been successfully executed.



Prog 10
Aim: To write an application in flash to create a function.
Procedure:
1. Select & open the macromedia flash and select new flash document.
2. Create function as name addfun, subfun & mulfun with two arguments, and display result.
3. Call the functions with value as argument.
4. Save the flash file as Function.fla and run the file by pressing Ctrl + Enter.

Program:
function addfun(x:Number, y:Number) {
trace( x + " + " + y + " = " + (x+y) );
}

function subfun(x:Number, y:Number) {
trace( x + " - " + y + " = " + (x-y) );
}

function mulfun(x:Number, y:Number) {
trace( x + " * " + y + " = " + x*y );
}

addfun(5, 6);
subfun(4, 2);
mulfun(2, 6);

Output:
[image: ]

Conclusion: The above program to create a function has been successfully executed.



Prog 11
Aim: To write an application in flash to assign action to the button.
Procedure:
1. Select & open the macromedia flash and select new flash document.
2. Select the button as follows, insert -> new symbol -> button.
3. In the time line it shows mouse Up, Down, Over, Hit.
4. Select the tool and draw rectangle box and insert text as HOME.
5. Select over the right click, insert key frame and change the color as blue.
6. Again select down right click, insert key frame and change the color as green.
7. Then click the scene 1 menu then the window option under that choose library option and it will display the button and select and drag on the scene 1.
8. In that behaviour under that we can choose plus option it will display some options under that we choose content on web page.
9. Save the flash file as ButtonAction.fla and run the file by pressing Ctrl + Enter.

Output:
[image: ]   [image: ]


Conclusion: The above program to assign action to the button has been successfully executed.





Prog 12
Aim: To write an action script application for adding two no’s using function.
Procedure:
1. Select & open the macromedia flash and create action script document.
2. Create a class named Addition
3. Create a function addResult with two arguments/parameters.
4. Calculate the argument value and display as result.
5. Create a flash file and make an object for the Addition class.
6. Call the functions with object and pass value as argument.
7. Run the file by pressing Ctrl + Enter.

Program:
File Name: Addition.as
class Addition {
public function addResult(x:Number, y:Number):Void {
trace(x + " + " + y + " = " + (x+y));
}
}

File Name: Addition.fla
var addition:Addition = new Addition();
addition.addResult(5, 6);

Output:
[image: ]

Conclusion: The above program to adding two no’s using function has been successfully executed.




Prog 13
Aim: To write an action script application to create dynamic class.
Procedure:
1. Select & open the macromedia flash and create action script document.
2. Create a dynamic class named DynamicProg using dynamic keyword and leave it empty.
3. Create a flash file and make an object for the DynamicProg class.
4. Create a variable for the class and print its value.
5. Run the file by pressing Ctrl + Enter.

Program:
File Name: DynamicProg.as
dynamic class DynamicProg {
}

File Name: DynamicProg.fla
var dp:DynamicProg = new DynamicProg();
dp.n = 5;
trace(dp.n);

Output:
[image: ]

Conclusion: The above program to create dynamic class has been successfully executed.



Prog 14
Aim: To write an action script application to accept any type of data.
Procedure:
1. Select & open the macromedia flash and create action script document.
2. Create a function having argument of Object type and display the argument value.
3. Create a flash file and make an object for the .as class.
4. Pass the different value to the function.
5. Run the file by pressing Ctrl + Enter.

Program:
File Name: AnyTypeOfData.as
class AnyTypeOfData {
	public function anyData(x:Object):Void {
		trace("Your Message : " + x);
	}
}

File Name: AnyTypeOfData.fla
var anyTypeOfData:AnyTypeOfData = new AnyTypeOfData();
anyTypeOfData.anyData("Macromedia Flash");
anyTypeOfData.anyData(15);
anyTypeOfData.anyData(15.2645);
anyTypeOfData.anyData('a');

Output:
[image: ]

Conclusion: The above program to accept any type of data has been successfully executed.



Prog 15
Aim: To write an action script application to implement constructor.
Procedure:
1. Select & open the macromedia flash and create action script document.
2. Create a class named ConstructorProg and make a constructor and display message.
3. Create a flash file and make an object for the class.
4. Run the file by pressing Ctrl + Enter.

Program:
File Name: ConstructorProg.as
class ConstructorProg {	
	function ConstructorProg(x:Number, y:Number) {
		trace("Parameterized Constructor Invoked.");
		trace(x + " + " + y + " = " + (x+y));
	}
	
}

File Name: ConstructorProg.fla
var cp:ConstructorProg = new ConstructorProg(5, 6);


Output:
[image: ]

Conclusion: The above program to implement constructor has been successfully executed.

Prog 16
Aim: To write an action script application to implement Sub Class and Class Property.
Procedure:
1. Select & open the macromedia flash and create action script document.
2. Create a class named person, declare variables and implement setter and getter of variables.
3. Create another class named as student, and declare some variable and also make setter and getter of variables and Extends the person class.
4. Create object for the student class and set and get the value using getter and setter.
5. Run the file by pressing Ctrl + Enter.

Program:
File Name: Person.as
class Person {
	var name:String;
	var age:Number;	
	public function setName(name:String):Void {
		this.name = name;
	}
	public function setAge(age:Number):Void{
		this.age = age;
	}	
	public function getName():String {
		return this.name;
	}	
	public function getAge():Number {
		return this.age;
	}
}

File Name: Student.as
class Student extends Person {
	var roll:String;
	var course:String;	
	public function setRoll(roll:String):Void {
		this.roll = roll;
	}
	public function setCourse(course:String):Void{
		this.course = course;
	}	
	public function getRoll():String {
		return this.roll;
	}	
	public function getCourse():String{
		return this.course;
	}	
}

File Name: SubClassProperty.fla
var student:Student = new Student();
student.setName("Raju");
student.setAge(34);
student.setRoll("15781F0029");
student.setCourse("MCA");
trace("Name : " + student.getName());
trace("Age : " + student.getAge());
trace("Roll : " + student.getRoll());
trace("Course : " + student.getCourse());


Output:
[image: ]

Conclusion: The above program to implement Sub Class and Class Property has been successfully executed.



Prog 17
Aim: To write an action script application to implement this keyword.
Procedure:
1. Select & open the macromedia flash and create action script document.
2. Create a class named AdditionThis and declare two variables and make a function that takes two argument having same name as class variable.
3. Set the argument value into the class variable by using this keyword.
4. Create a flash file and make an object for the class and Call the function using object.
5. Run the file by pressing Ctrl + Enter.

Program:
File Name: AdditionThis.as
class AdditionThis {
	var x:Number;
	var y:Number;	
	public function setValue(x:Number, y:Number):Void {
		this.x = x;
		this.y = y;
	}	
	public function resultDisplay():Number {
		return x+y;
	}
}

File Name: AdditionThis.fla
var at:AdditionThis = new AdditionThis();
at.setValue(5, 6);
trace(at.resultDisplay());

Output:
[image: ]

Conclusion: The above program to implement this keyword has been successfully executed.
Prog 18
Aim: To write an action script application to implement setter and getter.
Procedure:
1. Select & open the macromedia flash and create action script document.
2. Create a class named SetterGetter and make a setter and getter that holds the value
3. Create a flash file and make an object for the class
4. Create object for the class and use the functions.
5. Run the file by pressing Ctrl + Enter.

Program:
File Name: SetterGetter.as
class SetterGetter {
	var x:Number;
	var y:Number;	
	public function setXValue(x:Number):Void {	this.x = x;	}	
	public function setYValue(y:Number):Void {	this.y = y;	}	
	public function getXValue():Number 	    {	return this.x;	}	
	public function getYValue():Number 	    {	return this.y;	}
}

File Name: SetterGetter.fla
var setterGetter:SetterGetter = new SetterGetter();
setterGetter.setXValue(5);
setterGetter.setYValue(6);
var x = setterGetter.getXValue();
var y = setterGetter.getYValue();
trace(x + " + " + y + " = " + (x+y));

Output:
[image: ]

Conclusion: The above program to implement this keyword has been successfully executed.

Prog 19
Aim: To write an action script application to show the concept of Inheritance.
Procedure:
1. Select & open the macromedia flash and create action script document.
2. Create a class and declare some variable.
3. Create another class and declare some variable and extends first class.
4. Create a flash file and make an object of second class.
5. Display the variable value using the object.
6. Run the file by pressing Ctrl + Enter.
Program:
File Name: InheritanceVariable.as
class InheritanceVariable {
	var name:String = "Max";
	var age:Number = 23; 
}

File Name: InheritanceVariableCaller.as
class InheritanceVariableCaller extends InheritanceVariable {
	var collegeName:String = "SVCET";
}

File Name: InheritanceVariableCaller.fla
var x:InheritanceVariableCaller = new InheritanceVariableCaller();
trace("Name : " + x.name);
trace("Age : " + x.age);
trace("College : " + x.collegeName);

Output:
[image: ]

Conclusion: The above program to show the concept of Inheritance has been successfully executed.


Prog 20
Aim: To write an action script application to show the concept of Class method inheritance.
Procedure:
1. Select & open the macromedia flash and create action script document.
2. Create a class and implement a function.
3. Create another class and declare a function and extends the first class.
4. Create a flash file and make an object of second class and call the methods.
5. Run the file by pressing Ctrl + Enter.
Program:
File Name: ClassMethodInheritance.as
class ClassMethodInheritance {
	function display():Void {
		trace("This is display() from Super class");
	}
}

File Name: ClassMethodInheritanceCaller.as
class ClassMethodInheritanceCaller extends ClassMethodInheritance {
	function display1():Void {
		trace("This is display1() from Base class");
	}
}

File Name: InheritanceVariableCaller.fla
var cic:ClassMethodInheritanceCaller = new ClassMethodInheritanceCaller();
cic.display();
cic.display1();

Output:
[image: ]

Conclusion: The above program to show the concept of Class method inheritance has been successfully executed.


Prog 21
Aim: To write an action script application to show the concept of Property Overriding.
Procedure:
1. Select & open the macromedia flash and create action script document.
2. Create a class and declare any variable.
3. Create another class and declare same variable and extends first class.
4. Implement display method and display variable value.
5. Create a flash file and make an object of second class and call the methods.
6. Run the file by pressing Ctrl + Enter.
Program:
File Name: Demo.as
class Demo {
	var a:Number = 10;
}

File Name: Demo1.as
class Demo1 extends Demo {	
	var a:Number = 20;	
	function display():Void {
		trace("Super class a : " + super.a); // super.a for access the super class a variable
		trace("Base class a : " + a);
	}
}

File Name: InheritanceVariableCaller.fla
var d1:Demo1 = new Demo1();
d1.display();

Output:
[image: ]

Conclusion: The above program to show the concept of Property Overriding has been successfully executed.


Prog 22
Aim: To write an action script application to show the concept of Method Overriding.
Procedure:
1. Select & open the macromedia flash and create action script document.
2. Create a class and declare any method.
3. Create another class and declare same method, using super keyword call super class method.
4. Create a flash file and make an object of second class and call the methods.
5. Run the file by pressing Ctrl + Enter.
Program:
File Name: Demo.as
class Demo {
	function display():Void {
		trace("This demo() in super class.")
	}
}

File Name: Demo1.as
class Demo1 extends Demo {
	function display():Void {
		super.display(); //Calling Super Class display() method.
		trace("This demo() in Base class.")
	}
}

File Name: DemoCaller.fla
var demo1:Demo1 = new Demo1();
demo1.display();

Output:
[image: ]

Conclusion: The above program to show the concept of Method Overriding has been successfully executed.


Prog 23
Aim: To write an action script application to show the Constructor Function Inheritance.
Procedure:
1. Select & open the macromedia flash and create action script document.
2. Create a class and implement constructor.
3. Create another class and declare constructor and extends first class.
4. Create a flash file and make an object of second class and call the methods.
5. Run the file by pressing Ctrl + Enter.
Program:
File Name: Demo.as
class Demo {
	function Demo() {
		trace("This is Super class Demo() constructor.");
	}
}

File Name: Demo1.as
class Demo1 extends Demo {
	function Demo1() {
		// Here first invoke the super class Constructor then the next line will execute.
		trace("This is Base class Demo1() constructor.");
	}
}

File Name: DemoCaller.fla
var demo1:Demo1 = new Demo1();

Output:
[image: ]

Conclusion: The above program to show the concept of Method Overriding has been successfully executed.


Prog 24
Aim: To write an action script application to show the concept of Interface.
Procedure:
1. Select & open the macromedia flash and create action script document.
2. Create an interface and implement method.
3. Create class and implement interface and override the method.
4. Create a flash file and make an object of second class and call the methods.
5. Run the file by pressing Ctrl + Enter.
Program:
File Name: DemoInterface.as
interface DemoInterface {
	public function display():Void
	public function displayAdd(a:Number, b:Number):Number
}

File Name: DemoClass.as
class DemoClass implements DemoInterface {
	public function display():Void {
		trace("This function having no argument")
	}
	public function displayAdd(a:Number, b:Number):Number {
		return a+b;
	}
}

File Name: DemoCaller.fla
var dc:DemoClass = new DemoClass();
dc.display();
trace("5 + 9 = " + dc.displayAdd(5, 9))

Output:
[image: ]

[bookmark: _GoBack]Conclusion: The above program to show the concept of Interface has been successfully executed.


Prog 25
Aim: To write an action script application to show the concept of interface Inheritance.
Procedure:
1. Select & open the macromedia flash and create action script document.
2. Create two interface file and extends them
3. Create class file and implement second interface
4. Create a flash file and make an object of second class and call the methods.
5. Run the file by pressing Ctrl + Enter.
Program:
File Name: DemoInterface1.as
interface DemoInterface1 {	public function display():Void	}

File Name: DemoInterface2.as
interface DemoInterface2 extends DemoInterface1 {	
	public function displayAdd(a:Number, b:Number):Number
}

File Name: DemoClass.as
class DemoClass implements DemoInterface2 {
	public function display():Void {
		trace("This display() from DemoInterface1");
	}	
	public function displayAdd(a:Number, b:Number):Number {
		trace("This displayAdd(a:Number, b:Number):Number from DemoInterface2");
		return a+b;
	}
}

File Name: DemoCaller.fla
var dc:DemoClass = new DemoClass();
dc.display();
trace("5 + 9 = " + dc.displayAdd(5, 9));

Output:
[image: ]
Conclusion: The above program to show the concept of interface Inheritance has been successfully executed.

Prog 26
Aim: To write an action script application to show the concept of package.
Procedure:
1. Select & open the macromedia flash and create action script document.
2. Create package mypack and create a class file
3. Create package mypack -> samplepack and create a class file
4. In root directory create a flash file and import both package and make an object of both class and call the methods.
5. Run the file by pressing Ctrl + Enter.
Program:
File Name: SamplePack.as
class mypack.sample.SamplePack {
	public function disp():Void {
		trace("This message by disp() from mypack->sample->SamplePack.as class");
	}
}

File Name: DemoPack.as
class mypack.DemoPack {
	public function display():Void {
		trace("This msg by display() from mypack->DemoPack.as class");
	}
}

File Name: Demo.fla
import mypack.*;
import mypack.sample.*;

var dp:DemoPack = new DemoPack();
dp.display();
var sp:SamplePack = new SamplePack();
sp.disp();

Output:
[image: ]
Conclusion: The above program to show the concept of package has been successfully executed.
Prog 27
Aim: To write an action script application to show the concept of Exception Handling.
Procedure:
1. Select & open the macromedia flash and create action script document.
2. Create a class file and make a function that checks the argument and throw the exception.
3. Create a flash file and make an object of class and catch the exception and display result.
4. Run the file by pressing Ctrl + Enter.
Program:
File Name: ExceptionClass.as
class ExceptionClass {
	public function getVal(a:Number, b:Number):Number {
		if(b == 0) {
			throw new Error("divide by zero");
		} else {
			return a/b;
		}		
	}	
}

File Name: ExceptionClass.fla
var ec:ExceptionClass = new ExceptionClass();
try {
	trace("Operation 1:");
	var result = ec.getVal(5, 2);
	trace("Result : " + result);
} catch(e) {
	trace(e.toString());
}

try {
	trace("Operation 2:");
	var result = ec.getVal(5, 0);
	trace("Result : " + result);
} catch(e) {
	trace(e.toString());
} finally {
	trace("Executed Successfully.");
}







Output:
[image: ]

Conclusion: The above program to show the concept of Exception Handling has been successfully executed.



Prog 28
Aim: To write an action script application to show the concept of Multiple Exception.
Procedure:
1. Select & open the macromedia flash and create action script document.
2. Create a class file and make a function that checks the argument and throw the exception.
3. Create a flash file and make an object of class and catch the exception and display result.
4. Run the file by pressing Ctrl + Enter.
Program:
File Name: MultipleException.as
class MultipleException {
	public function display(a:Number):Number {
		if(a < 0) {
			throw new Error(a + " is not valid no.");
		} else if( a == 0) {
			throw new Error("0 is not valid no.");
		} else {
			return a;
		}
	}
}

File Name: ExceptionClass.fla
var me:MultipleException = new MultipleException();
try {
	var x = me.display(-5);
} catch(e:Error) {
	trace(e.toString());
}

try {
	var x = me.display(0);
} catch(e:Error) {
	trace(e.toString());
}

try {
	var x = me.display(52);
	trace("Result : " + x);
} catch(e:Error) {
	trace(e.toString());
}





Output:
[image: ]

Conclusion: The above program to show the concept of Multiple Exception has been successfully executed.


Prog 29
Aim: To write a program to draw a circle.
Procedure:
1. Select & open the macromedia flash and create a new flash document & select action panel.
2. Write a program for creating a circle using the following function 
–root.CreateEmptyMovieClip(), lineStyle(), moveTo() and curveTo()
3. Run the file by pressing Ctrl + Enter.
Program:
File Name: Circle.fla
-root.CreateEmptyMovieClip("circle", 1);
with(-root.circle) {
	lineStyle(5, 0xff00ff, 100);
	moveTo(500, 500);
	curveTo(600, 500, 600, 400);
	curveTo(600, 300, 500, 300);
	curveTo(400, 300, 400, 400);
	curveTo(400, 500, 500, 500);
}

Output:
[image: ]

Conclusion: The above program to draw a circle has been successfully executed.


Prog 30
Aim: To write a program to draw a rectangle.
Procedure:
1. Select & open the macromedia flash and create a new flash document & select action panel.
2. Write a program for creating a rectangle using the following function 
–root.CreateEmptyMovieClip(), lineStyle(), moveTo() and curveTo()
3. Run the file by pressing Ctrl + Enter.
Program:
File Name: Rectangle.fla
-root.CreateEmptyMovieClip("Rectangle", 1);
with(-root.Rectangle) {
	lineStyle(5, 0x0f00ff, 100);
	moveTo(100, 100);
	lineTo(100, 200);
	lineTo(300, 200);
	lineTo(300, 100);
	lineTo(100, 100);
}

Output:
[image: ]

Conclusion: The above program to draw a rectangle has been successfully executed.


Prog 31
Aim: To write a program to draw a square.
Procedure:
1. Select & open the macromedia flash and create a new flash document & select action panel.
2. Write a program for creating a square using the following function 
–root.CreateEmptyMovieClip(), lineStyle(), moveTo() and curveTo()
3. Run the file by pressing Ctrl + Enter.
Program:
File Name: Rectangle.fla
-root.CreateEmptyMovieClip("square", 1);
with(-root.square) {
	lineStyle(5, 0x000fff, 100);
	moveTo(100, 100);
	lineTo(100, 200);
	lineTo(200, 200);
	lineTo(200, 100);
	lineTo(100, 100);
}

Output:
[image: ]

Conclusion: The above program to draw a square has been successfully executed.

Prog 32
Aim: To write a program in flash document for login validation.
Procedure:
1. Select & open the macromedia flash and create a new flash document and select layer
2. Design login form using gui tool from components panel, label for display message, textbox for input and button for operation.
3. Select the layer and write the code for username and password validation in Actions-Frame panel.
4. Run the file by pressing Ctrl + Enter.
Program:
File Name: Rectangle.fla
form = new Object();
form.click = function(evt) {
	if( (txtUname.text == "") || (txtPass.text == "") ) 	{
		trace("Please Enter Username and Password");
	} else if((txtUname.text == "abhi") && (txtPass.text == "abhi") ) {
		trace("Welcome, Successfully login");
	} else {
		trace("Invalid Username and Password");
	}
}
btnSubmit.addEventListener("click", form);

Output:
[image: ][image: ] 
Conclusion: The above program for login validation has been successfully executed.

Prog 33
Aim: To write a program in flash document to convert angles into radians.
Procedure:
1. Select & open the macromedia flash and create a new flash document and select layer
2. Design form using gui tool from components panel, label for display message for user, textbox for input and button for operation.
3. Select the layer and write the code for conversion in Actions-Frame panel.
4. Run the file by pressing Ctrl + Enter.
Program:
File Name: AngleMeasurement.fla
convert = new Object();
convert.click = function(evt) {
	var a:Number = Number(txtInput.text);
	txtRadian.text = a * (Math.PI / 180);
	txtSin.text = Math.sin(a);
	txtCos.text = Math.cos(a);
	txtTan.text = Math.tan(a);
}
btnConvert.addEventListener("click", convert);

Output:
 [image: ] 
Conclusion: The above program to convert angles into radians has been successfully executed.

Prog 34
Aim: To write a program in flash document to reverse a string.
Procedure:
1. Select & open the macromedia flash and create a new flash document and select layer
2. Design form using gui tool from components panel, label for display message, textbox for input and button for operation.
3. Select the layer and write the code for reversing a string in Actions-Frame panel.
4. Run the file by pressing Ctrl + Enter.
Program:
File Name: ReverseString.fla
reverse = new Object();
reverse.click = function(evt) {
	var a:String = txtInput.text;
	var b:String = "";
	var c:Number = a.length-1;
	while(c >= 0) {
		b = b + a.charAt(c);
		c--;
	}
	txtRevStr.text = b;
}
btnReverse.addEventListener("click", reverse);

Output:
 [image: ] 
Conclusion: The above program to reverse a string has been successfully executed
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